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Disclaimer 
The Ramona Optics MCAMⓇ is a Gigapixel MicroscopeTM that is provided as a beta-unit 
for use by the user “AS-IS” and any express or implied warranties, including but not 
limited to, the implied warranties of merchantability and fitness for a particular purpose 
are disclaimed. 
 
Licensing 
A copy of the license agreement is included along with the software package. If you have 
not received this agreement please contact Ramona Optics. 
 
All third party licenses can be found within the MCAM GUI by selecting “About” in the 
“Help” menu. 
 
Trademarks 
Ramona Optics® is a registered trademark of Ramona Optics, Inc.  
All other trademarks are the sole property of their respective owners. 
 
"Python®" and the Python® logos are trademarks or registered trademarks of the Python 
Software Foundation, used by Ramona Optics with permission from the Foundation. 
 
Contact 
Ramona Optics 
1000 West Main Street, Suite #2A 
Durham, NC 27701 
 
Phone: (919) 797 9975 
Email: info@ramonaoptics.com 
Website: ramonaoptics.com  
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Introduction 
 
The purpose of this manual is to guide users of the Multi-Camera Array Microscope 
(MCAM) through basic MCAM workflows with step by step instructions. For more 
information on the MCAM and detail surrounding all aspects of the MCAM hardware and 
software, please see the MCAM User Manual. Additionally, to use the MCAM 
programmatically, please see our online documentation at docs.ramonaoptics.com. 
 
 
For information about the MCAM platform please email us at info@ramonaoptics.com. 
 
For assistance with MCAM usage, please email us at help@ramonaoptics.com. 
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Acquire an Image 
Capturing an image is the simplest form of data acquisition within the MCAM platform. 
 

 
 

Step Function 

1 Open the MCAM software. 

2 In the left side panel, in the top left corner, click “Select a File Location”. Always 
select a folder on the “MCAM_data” drive to store data from MCAM acquisitions. 
The “File Location” will be displayed in the left side panel once defined. 

3 Enter a Filename for the image. A timestamp will automatically be appended to 
the chosen filename. 

4 Adjust imaging settings in the left side panel to optimize image quality. 

5 Click Save Image as NC or Save Image as Tif to save the image. 
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Acquire a Z Stack 
A z-stack is a series of images taken at different focal planes along the z-axis, capturing a 
3D representation of a specimen. It's commonly used in microscopy to reconstruct 
detailed structures or features within samples. With the MCAM, z-stacks can be easily 
acquired by automating movement of the z-stage alongside image acquisition. 
 

 
 

Step Function 

1 Open the MCAM software. 

2 Go to Assays > Acquire Z Stack. 

3 Enter a “Start height” and “End height” representing z-stage positions where 
the z-stack will start and stop. Sometimes it works well to find an optimal focal 
plane and choose this as the “Mid height” and then set the Start and End a 
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millimeter below and above respectively. 

4 Enter either “Step size” or “Number of Steps” to determine the z-axis 
resolution. The second of these two parameters will update automatically. 

5 Select other options as needed regarding projection type, delays, and save 
mode. Please see the MCAM™ User Manual for more information regarding 
these options. 

6 Select a File Location. Always select a folder on the “MCAM_data” drive to store 
data from MCAM acquisitions. The “File Location” will be displayed in the panel 
once defined. 

7 Enter a Folder Name for the z-stack. A timestamp will automatically be 
appended to the chosen folder name. 

8 Adjust imaging settings in the left side panel to optimize image quality. 

9 Click Acquire Z Stack to initiate the acquisition. 
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Acquire an XYZ Stack 
In Screening Mode with a 96-well plate it is often useful to acquire a z-stack at high 
resolution, however because the optical head views twenty four of ninety six wells at a 
time, the head needs to step between four x, y locations to acquire images of all ninety six 
wells. Using an XYZ stack, movement of the X, Y and Z stages are synchronized with 
image acquisition to capture volumetric scans. 
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Step Function 

1 Open the MCAM software. 

2 Ensure that “Well A1” is visible in the top left corner of the imaging window. 
Use the X and Y stage controls in the left panel to center Well A1 in this camera 
view. It can be helpful to unstitch the camera views to view just the top left 
corner and center this well within the camera view. Unstitch views by selecting 
Advanced>Stitch Image. 

3 Go to Assays > Acquire XYZ Stack. 

4 Enter a “Start height” and “End height” representing z-stage positions where 
the z-stack will start and stop. Sometimes it works well to find an optimal focal 
plane and choose this as the “Mid height” and then set the Start and End a 
millimeter below and above respectively. 

5 Enter either “Step size” or “Number of Steps” to determine the z-axis 
resolution. The second of these two parameters will update automatically. 

6 Y and X Stage parameters are populated automatically. Step size defaults to 
9mm so that the optical head can move correctly to view all wells of a 96-well 
plate. 

7 Select other options as needed regarding projection type, delays, and save 
mode. Please see the MCAM User Manual for more information regarding these 
options. 

8 Select a File Location. Always select a folder on the “MCAM_data” drive to store 
data from MCAM acquisitions. The “File Location” will be displayed in the panel 
once defined. 

9 Enter a Name for the acquisition. A timestamp will automatically be appended to 
the selected name. 

10 Adjust imaging settings in the left side panel to optimize image quality. 

11 Click Acquire XYZ Stack to initiate the acquisition. 
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Acquire a Video 
Videos can be streamed and acquired from all cameras of the MCAM simultaneously. 
 

 
 

Step Function 

1 Open the MCAM software. 

2 Go to Assays > Acquire Video. 

3 Select a File Location. Always select a folder on the “MCAM_data” drive to store 
data from MCAM acquisitions. The “File Location” will be displayed in the panel 
once defined. 

4 Enter a Name for the acquisition. A timestamp will automatically be appended to 
the selected name. 

5 A start delay is optional and can be entered to delay the acquisition start from 
the time “Acquire Video” is clicked. 
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6 Select Save Format. It is recommended to compress videos during acquisition 
by saving to MP4 format. 

7 Define Frame Rate. The current maximum values for High resolution, Standard 
and High Frame Rate resolutions are 23, 80, and 160 fps respectively. Acquiring 
at high frame-rates increases data sizes, so it is recommended to minimize the 
frame-rate for your application in order to decrease data sizes. 

8 Define Acquisition Duration.  

9 The three status bars reflect estimated system performance and storage 
capacity. Ensure that all three bars are blue. If any are red, modify imaging 
parameters to allow acquisition. 

10 Click Allocate Memory to prepare the system for acquisition. 

11 Click Acquire Video to initiate the acquisition. 
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Tools 
Available both in the  MCAM Software and the  MCAM Viewer. 

Color picker 
When the Color Picker tool is selected, clicking on the screen will display the pixel color at 
this location. Values are displayed as (Red, Green, Blue) integers corresponding to the 
three color channels of the image. 
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Step Function 

1 Open the MCAM software. 

2 Go to Tools > Color Picker. 

3 Click on a pixel in the image to get the displayed color at the location. 

4 In the MCAM software, go to View which will give the user several options to alter the 
viewing color space. Changing this will alter the pixel values displayed by the color 
picker. 

5 To take another measurement simply repeat step 3. To remove the Color Picker repeat 
step 2.  

 

Length Tool 
When the Length Tool is selected, straight lines can be measured on the screen. The 
measurement and unit will be displayed on the screen.  
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Step Function 

1 Open the MCAM software. 

2 Go to Tools > Length Tool. 

3 Click once with the left mouse button to define the beginning of the line, move 
the cursor to extend the line and finally click again with the left mouse button 
to define the end of the line. 

4 To take another measurement simply repeat step 3. To remove the Length Tool 
repeat step 2. 

 

Rectangle Tool 
When the Rectangle Tool is selected, rectangles can be drawn across a desired area of 
the screen. Height, width, area and their corresponding units will be displayed on the 
screen.  
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Step Function 

1 Open the MCAM software. 

2 Go to Tools > Rectangle Tool. 

3 Click once with the left mouse button to define one corner of the rectangle, move the 
cursor to extend the area covered by the rectangle and click again with the left 
mouse button to define the second defining corner of the rectangle. 
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4 To take another measurement simply repeat step 3. To remove the Rectangle Tool 
repeat step 2.  

 

Circle Tool 
When the Circle Tool is selected, circles can be drawn across a desired area of the 
screen. Diameter, area and their corresponding units will be displayed on the screen.  

 

 

Step Function 
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1 Open the MCAM software. 

2 Go to Tools > Circle Tool. 

3 Click once with the left mouse button to define the center of the circle, move the cursor 
to extend the circle's radius and finally click once with the left mouse button a second 
time to define the final shape of the circle. 

4 To take another measurement simply repeat step 3. To remove the Circle Tool repeat 
step 2.  

 

Ellipse Tool 
When the Ellipse Tool is selected, ellipses can be drawn across a desired area of the 
screen. Width, height, area and their corresponding units will be displayed on the screen.  
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Step Function 

1 Open the MCAM software. 

2 Go to Tools > Ellipse Tool. 

3 Start by creating a circle by clicking once with the left mouse button to define the 
center of the circle. Move the cursor to extend the circle's radius and finally click once 
with the left mouse button a second time to define the final shape of the circle. 

4 Once the desired circle is created, click once with the left mouse button to shape the 
ellipse based on this circle. Move the cursor to adjust the ellipse shape/direction and 
click once with the left mouse button to define the final ellipse shape. 

5 To take another measurement simply repeat steps 3 and 4. To remove the Ellipse Tool 
repeat step 2.  
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Recommended Video Acquisition Parameters 
 

Workflow/ 
Purpose 

Imaging 
Parameter 

Recommended Setting 

Morphology Imaging Mode High Resolution, Bin1 

Transmission 
Illumination 

Transmission Brightfield 

Exposure 10 milliseconds 

Brightness 30% 

Digital Gain 1.0 

Analog Gain 1.0 

Motion Tracking 
Behavioral 
Analysis 

Imaging Mode High Frame Rate, Bin4 

Transmission 
Illumination 

Transmission IR850 

Exposure 2 milliseconds 

Brightness 60% 

Digital Gain 2.0 

Analog Gain 1.0 
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Create a Well Alignment File 
This step creates a file that will be used to detect well plate wells for analysis. 

 
 

Step Action 

1 Open .nc dataset file in MCAM Viewer or open the MCAM GUI 

2 Go to Tools > Well Alignment to open Well Alignment Panel 

3 Under Well Format, enter values into Columns, Rows, and Well Diameter (pixels) 
fields for well plate depicted in open .nc dataset file that correspond to values in 
Table 1: Well Plate Configuration below 
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Upon entry of the above, Well Diameter (mm) field will auto-update 

3a If well plate contains square wells, check the box beside Square Wells  

4 Click Detect Well Alignment. Well Indicators will now appear. To create Well 
Alignment File for tracking, Well Indicators must be aligned with wells 

5 Well Indicators may not be aligned with wells after Step 4. If so:  

5a Double click on center point each of the 4 corner Well Indicators, hold, and 
drag into alignment with each of the 4 corner wells. 

5b In Well Alignment panel, click Update Well Alignment to align remaining Well 
Indicators 

5c Make individual well adjustments by clicking and dragging any misaligned Well 
Indicators to correct locations and clicking Update Well Alignment. 

5d To simultaneously resize all Well Indicators in the GUI, double click on any Well 
Indicator boundary, hold, and drag 

6 Click Save Well Alignment in the Well Alignment panel to save the Well 
Alignment File. 

 
 
Table 1: Well Plate Configuration 
The metrics in this table describe common well plate configurations. The MCAM uses 
them to detect well locations in a .nc dataset file. Note: For use with tracking workflows, 
well diameters must match the specified values. Pixel widths that do not match these 
values are not supported, and data sets collected with incorrect values will not be 
successfully analyzed. 
 
 

Table 1 - Creating a Well Alignment File:  Well Plate Configuration 

Well Plate Configuration Columns Rows Well Diameter 
(pixels) 

96-well plate 12 8 1024 

48-well plate 8 6 1408 

24-well plate 6 4 2048 

12-well plate (Ramona custom well plate) 3 4 2056 
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Compressing .nc Dataset Files 
This step compresses the .nc dataset file to prepare it for analysis.  
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Single File Compression 
 

Step Function 

1 Open .nc dataset file in MCAM Viewer 

2 Go to File > Compress > Compress Video 

3 In Compress Dataset panel, click Select Alignment File 

4 Select Well Alignment File created in 1) Creating a Well Alignment File, 
corresponding to well plate depicted in open .nc dataset file 
 
Blue circles will appear, indicating locations to be extracted as wells. 

5 If interested in the Compression Options visit the MCAM User Manual and look 
at the Video Compression -> Compression Options subsection. 

6 Click Compress.  
 
New Compressed Data Folder named “filename_export”  will now be generated 
in same directory as original .nc dataset file 

Batch File Compression 
Batch file compression allows the user to compress multiple .nc dataset files at once.  
All files to undergo batch compression must share a Well Alignment File. 
 

Step Function 

1 In MCAM™ Viewer, go to File > Compress > Compress Video 

2 In Compress Dataset panel, check Batch Analysis box 

3 Select Add Files to add files to list to compress. Only add .nc dataset files that 
can use the same Well Alignment File. 

4 Select Well Alignment File created in “Creating Well Alignment Files”, 
corresponding to well plates in files added to list to compress 
 
Blue circles will appear, indicating locations to be extracted as wells. 

5 Click Compress.  
 
New Compressed Data Folders named “filename_export”  will now be generated 
in same directory as original .nc dataset files 
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Zebrafish Tracking 

The Ramona MCAM supports fully automated zebrafish tracking across 96-, 24-, and 
custom 12-well plates in Visible and Infrared transmission illumination. 8 key-points on the 
body of a zebrafish are tracked as a “skeleton” as shown below: 
 

 
 
Zebrafish tracking generates a diverse and detailed set of outputs, from raw data 
describing the x- and y-coordinates of tracking key-points over time to various derived 
metrics and visualizations, listed out and described in detail in Table 2: Zebrafish Tracking 
Output File Descriptions. 
 
Users may use a .nc dataset file captured with the Ramona MCAM to generate zebrafish 
tracking outputs in 3 steps: 

1.​ Creating a Well Alignment File - See section titled “Creating Well Alignment Files” 
2.​ Compressing the original .nc dataset file using the generated Well Alignment File 

- See section titled “Compressing .nc Dataset Files” 
3.​ Tracking the zebrafish -See below: 

Acquire a Zebrafish Assay Video 
Acquiring a zebrafish assay video is an extension of acquiring a video, but with added 
options for flexible zebrafish assays. 
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Step Function 

1 Open the MCAM GUI. 

2 Go to Assays > Animal Tracking. 

3 Select a Well Alignment file to identify the well locations. See “Create a Well 
Alignment File” if you do not have one already. This step is necessary for the 
analysis if you have chosen “Save to Single MP4”.  

4 Select a File Location. Always select a folder on the “MCAM_data” drive to store 
data from MCAM™ acquisitions. The “File Location” will be displayed in the panel 
once defined. 

5 Define a Filename. This should be a unique identifier to define the dataset. A 
timestamp will be automatically appended to the chosen name. 

6 (Optional) Notes can be added to the “Additional Information” field. 

7 Adjust imaging settings in the left side panel to optimize image quality. For 
behavioral recordings we recommend IR transmission illumination with 60% 
brightness, 2 millisecond exposure, 2.0 digital gain, and 1.0 analog gain. 
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8 Select Full Array or Subset to define which cameras are acquiring video. Full 
array is selected by default. 

9 Select a save format for the video acquisition. MP4 is generally recommended 
as this saves on data sizes and is what is used in the analysis pipeline. 

10 In the top left corner of the MCAM™ GUI, select High Frame Rate from the 
selection menu box. 

11 Define Frame Rate. The current (2024/04/12) maximum values for High 
resolution, Standard and High Frame Rate resolutions are 23, 80, and 160 fps 
respectively. Acquiring at high frame-rates increases data sizes, so it is 
recommended to minimize the frame-rate for your application in order to 
decrease data sizes. For behavioral video acquisitions we recommend using 30 
fps for general purpose and longer acquisitions focused on distance traveled 
metrics and 160 fps for shorter recordings where tail analytics are required. 

12 Define the Acquisition Duration. 

13 Ensure acquisition requirements are within the MCAM™ capabilities. The three 
indicator bars representing MCAM™ Bandwidth, Computer Memory, and SSD 
Storage should be blue. If they are red, this indicates that the workstation 
cannot run the current settings. 

14 (Optional) If background visible light is required, define the background 
intensity lux value.  

15 (Optional) Define a start delay for the experiment. 

16 (Optional) Define stimuli. For more information see “Defining Stimuli”. 

17 Save the acquisition protocol by clicking “Save” next to the Assay Protocol field 
at the top of the panel if this will be a commonly used assay which will save time 
setting this up again and ensure repeatability of experiments. 

18 Click Prepare Video. 

19 Start the acquisition by clicking “Acquire Video”. 

Acquire a Zebrafish Visual Motor Response (VMR) Dataset 
The Zebrafish Visual Motor Response (VMR) is a frequently used assay characterizing 
behavior during light phase transitions. The Ramona MCAM allows for streamlined 
acquisition and analysis using a timelapse video acquisition coupled with light phase 
stimuli.  
The following instructions give an example assay setup for running an assay that has 150 
seconds background with visible lights on in which images are not acquired followed by 
30 seconds of light and 30 seconds of dark recording.  
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This sequence is repeated 4 times. The duration of each assay segment is 3.5 minutes 
while only one minute of this time is recorded saving on data sizes and future analysis 
computation time. Overall, this assay is very similar to running a stimulus video recording 
but iterated through timelapse mode for multiple acquisitions. 

 

 
 
 
 
 

Step Function 

1 Open the MCAM GUI. . 

2 Go to Assays > Zebrafish > Acquire Stimulus Timelapse. 

3 Select a Well Alignment File. 
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4 Set the acquisition framerate. We recommend 30 fps unless tail analysis is 
required which should likely be run at 160fps. 

5 Set the acquisition duration. Here we use a one minute duration as we would 
like to record 30 seconds of light and 30 seconds of dark. 

6 Set the background light intensity. Here we used a value of 700 lux but this 
value is very specific to each experiment and may change for your experiment. 
This is the light intensity that will remain on during visible light phases. 

7 Add a flash stimulus with 0 lux with 30 second duration that begins at 30 
seconds. This will create a dark phase half way through the one minute 
recording period for thirty seconds. 

8 Select a File Location. Always select a folder on the “MCAM_data” drive to store 
data from MCAM™ acquisitions. The “File Location” will be displayed in the panel 
once defined. 

9 Define a Filename. This should be a unique identifier to define the dataset. A 
timestamp will be automatically appended to the chosen name. 

10 Under timelapse settings, set a start delay of 2.5 minutes (150 seconds). 

11 Set the number of iterations the assay will run. Here we use a value of 4. 

12 Set the time lapse period. Here we use a value of 210 seconds (3.5 minutes) 
which is the total length of one assay segment. 

13 Save the time lapse assay protocol by clicking “Save” next to the Assay 
Protocol field at the top of the panel if this will be a commonly used assay which 
will save time setting this up again and ensure repeatability of experiments. 

14 Start the acquisition by clicking “Acquire Timelapse”. 

Acquire a Zebrafish Timelapse Stimulus Dataset for Acoustic 
Startle Response 
The following instructions give an example of assay setup for quantifying acoustic 
stimulus responses in larval zebrafish. This protocol is used to take successive short 
recordings with a tap stimulus in the middle of each recording. 
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Step Function 

1 Open the MCAM GUI. 

2 Go to Advanced > Additional Settings > Image Sensor. Choose 2048 x 
2048 pixels as the image size. This is the best setting if you are using 24- or 
96-well plates because the field of view sees all of each well and allows the 
cameras to capture frames at high frame rate.  

3 Select High Frame Rate for imaging mode in the top left corner of the screen.  

4 Go to Assays > Zebrafish > Acquire Stimulus Timelapse.  

5 Select a Well Alignment File. 

6 Set the background light intensity. Here we used a value of 700 lux but this 
value is very specific to each experiment and may change for your 
experiment. We recommend using the same intensity as the larvae were 
raised at.  

7 Set the acquisition framerate. For acoustic response tracking, we 
recommend 160 fps to capture high frequency movements. 
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8 Set the acquisition duration to a 10 seconds duration. 

9 Select “Tap” in the stimulus drop down menu. Set Start (sec) to 5. Then, 
click “Add Stimulus” to add the stimulus to the stimulus list. These settings 
make the tap stimulus happen right in the middle of your recording. 

10 Set the number of iterations the assay will run under timelapse settings. Here 
we use a value of 5.   

11 Set the time lapse period to 120 seconds (2 minutes) to ensure that zebrafish 
do not habituate to the stimulus. 

12 Save the timelapse assay protocol by clicking “Save” next to the Assay 
Protocol field at the top of the panel if this will be a commonly used assay 
which will save time setting this up again and ensure repeatability of 
experiments. 

13 Select a File Location. Always select a folder on the MCAM_data drive to 
store data from MCAM acquisitions. The “File Location” will be displayed in 
the panel once defined. 

14 Start the acquisition by clicking “Acquire Timelapse”. 
 

Tracking Analysis 
This step uses the Well Alignment File from 1) Creating a Well Alignment File and the 
Compressed Data Folder from 2) Compressing the Original Data File to generate zebrafish 
tracking outputs. 
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Single File Tracking 

Step Function 

1 Go to File > Open File. A popup for folder selection will appear.  
 
Click into the Compressed Data Folder of interest, then click Open in the popup 
to open Compressed Data Folder in MCAM Viewer 

2 Go to Assays > Animal Tracking to open Zebrafish Analysis panel. Well plate 
configuration (96-, 24- or custom 12-well) will be automatically detected by 
MCAM™ Viewer. 

3 If the Compressed Data Folder to be analyzed is a square well plate, check the 
box labeled Square Well Plate. 

4 All Zebrafish Tracking Outputs (described in Table 2: Zebrafish Tracking Output 
File Descriptions) are generated by default. If not all are necessary, check the 
box labeled Advanced Settings and uncheck boxes beside undesired Zebrafish 
Tracking Outputs to skip generation. 

5 Click Track Zebrafish to generate Zebrafish Tracking Outputs 

Batch File Tracking 
Batch file tracking allows the user to generate zebrafish tracking outputs for multiple 
Compressed Data Folders at once.  
 
All files to undergo batch tracking must share a Well Alignment File. 
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Step Function 

1 Go to File > Open File. A popup for folder selection will appear.  
 
Click into a Compressed Data Folder of interest, then click Open in the popup 
to open Compressed Data Folder in MCAM™ Viewer. 

2 Go to Assays > Zebrafish Assay to open Zebrafish Analysis panel. Well plate 
configuration (96-, 24- or custom 12-well) will be automatically detected by 
MCAM™ Viewer. 

3 If the Compressed Data Folder to be analyzed is a square well plate, check the 
box labeled Square Well Plate. 

4a In the Zebrafish Analysis panel, check the box labeled Batch Analysis. 

4b Select Add Files to add folders to list to track. Only add files compressed using 
the same Well Alignment File. 

4c All Zebrafish Tracking Outputs (described in Table 2: Zebrafish Tracking Output 
File Descriptions) are generated by default. If not all are necessary, check the 
box labeled Advanced Settings and uncheck boxes beside undesired 
Zebrafish Tracking Outputs to skip generation. 

5 Click Track Zebrafish to generate Zebrafish Tracking Outputs 

Morphology 

See Table 2: Zebrafish Tracking Output File Descriptions and MCAM User Manual for 
more detail. 

Motion, Orientation, Locomotion 

See Table 2: Zebrafish Tracking Output File Descriptions and MCAM User Manual for 
more detail. 

Tail Bends/Angle 

See Table 2: Zebrafish Tracking Output File Descriptions and MCAM User Manual for 
more detail. 
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Zebrafish Segmentation 
The Ramona MCAM supports fully automated segmentation of zebrafish from single 
frame and stack datasets. This functionality can be used to define a region of interest that 
is the zebrafish and perform further analysis within the region such as bulk fluorescence 
intensity quantification, blob counting, and region area quantification. When stack 
datasets are analyzed, contrast is measured within each segmented region and only the 
best focus frame of the stack is used for further analysis and visualization. For more 
information on the underlying mechanics of the segmentation workflow, please see the 
MCAM User Manual. 
 

 
 

Step Function 
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1 Acquire a XYZ-stack dataset using the XYZ-stack acquisition mode described 
above. 

2 Open the dataset in the MCAM™ Viewer by double clicking on the metadata.nc 
file or drag-and-dropping it into the viewer. 

3 Go to Tools > Segmentation to open the segmentation panel.  

4 Select a segmentation model specific to the current segmentation task from the 
model selection menu.  

5 If you would like to compute region areas, check “Compute Region Areas”. 

6 Select an SI unit for exported values. “Millimeters” is selected by default. 

7 Select a Pixel Intensity Threshold to use for fluorescence intensity and blob 
count quantification. Values below this threshold will be set to zero while values 
above remain unchanged. The default value of 55 was optimized for 
quantification of neutrophils in zebrafish. 

8 Select a color channel to be considered during analysis. Green is selected by 
default. 

9 If you would like to compute bulk fluorescence intensity, check “Compute 
Fluorescence Intensity”. 

10a If you would like to count blobs, check “Count Blobs”. 

10b If you plan to count blobs, set a minimum and maximum blob radius threshold 
for the size of the blob you plan to count. The larger this range is, the more 
computation is required during analysis which will increase analysis time. 
Consider that the width of one pixel on the screen is approximately 3 
micrometers in screening mode but each system is slightly different and for 
fine-tuning your specific pixel width should be considered. 

11 Click “Segment Instances” to run the analysis.  

12 Results are output to a new directory with the same name as the analyzed 
dataset with “_segmentation_results” appended. 

13 Segmentation visualizations are displayed in the MCAM Viewer. 
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Activity Metric 
Activity metric analysis provides a rapid method for computing movement in a video. This 
is accomplished by subtracting each pair of adjacent frames in a video to quantify pixel 
change. All pixels are treated equally so while total movement is measured over time, we 
cannot determine “how” something within a frame moves. 
 

 

 

Step Function 

1 Open the MCAM Viewer and click the Open Dataset button. 
 
Click into the dataset of interest, then click Open in the popup to open dataset 
in MCAM Viewer 

2 Go to Assays > Activity Analysis to open the Activity Analysis panel.  
 
Well plate configuration (24-, 48-, or 96-well) will be automatically detected by 
MCAM Viewer. 

3 All Activity Analysis Outputs (described in MCAM Viewer Activity Metric 
Analysis) are generated by default. If not all are necessary, uncheck the box 
pertaining to the output you wish not to generate.  
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4 The features found within Advanced Settings are also activated by default. Click 
on Advanced Settings if there are any changes that need to be made / any 
features that you want turned off.  

5 Click Analyze Activity to generate Activity Analysis Outputs 

 

Zebrafish Embryonic Photomotor Response (EPMR) Assay 

 
 
The EPMR assay measures the responses of embryonic zebrafish upon exposure to 
flashing light stimuli. The MCAM Zebrafish EPMR Assay enables users to set up stimuli 
and data capture for an EPMR assay experiment. 
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Step Action 

1 Go to Assays > Zebrafish > Acquire Zebrafish EPMR to open the Acquire 
Zebrafish EPMR Panel.  
 
Once the Acquire Zebrafish EPMR Panel opens, image acquisition settings will 
automatically adjust to empirically verified optimal values for EPMR assays. 
However, image acquisition settings can still be modified by the user. 

2 Click Select Alignment to select a Well Alignment File (see Create a Well 
Alignment File for more information, and for instructions on creating a Well 
Alignment File). 
 
The well plate configuration documented within the selected Well Alignment File 
should match the configuration of the well plate being used in the EPMR assay. 

3 (Optional) In the Additional Information field, enter any notes about the EPMR 
assay being conducted. 

4 To save assay data as an .nc dataset file, select Save to RAM under Save 
Format. 
 
To save assay data as an MP4 file, select Save to MP4 under Save Format. 

5 (Optional) Assay Settings open with preset suggested values. However, to 
customize assay data capture, under Assay Settings, set durations of: 

●​ Background Period (sec) - time before First Light Flash 
●​ Excitatory Period (sec) - time between First Light Flash and Second Light 

Flash 
●​ Refractory Period (sec)  - time after Second Light Flash 
●​ First Light Flash (sec) 
●​ Second Light Flash (sec) 

 
as per EPMR assay experimental requirements. 

6 (Optional) Assay Settings open with preset suggested values. However, to 
customize assay data capture, under Assay Settings, set intensity values of: 

●​ First Light Flash 
●​ Second Light Flash 

 
as per EPMR assay experimental requirements. 

7 (Optional) Enter a value in the Start Delay field to delay the start of the assay 
data capture sequence defined in Steps 5 and 6 above. 

8 Click Select File Location to select a workspace. Always select a folder on the 
“MCAM_data” drive to store data from MCAM™ acquisitions. The “File Location” 
will be displayed in the left side panel once defined. 
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9 Define a Filename to name the folder into which all generated files will be 
saved. A timestamp will be automatically appended to this name. 

10 (Optional) At the top of the panel under “Assay Protocol” click Save to save this 
assay protocol for future use. 
 
In the future, load previously saved assay data capture parameters by clicking 
the Load button under “Assay Protocol” and select the appropriate EPMR Assay 
JSON file. 

11 If Save to Ram was selected as the Save Format, click the Prepare Video button 
to set up the MCAM system to capture EPMR assay video data. 

12 Click the Acquire Video button to begin EPMR assay data capture. 

Zebrafish Tail Coiling Assay 
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Step Action 

1 Go to Assays > Zebrafish > Acquire Zebrafish Tail Coil to open the Acquire 
Tail Coil Panel.  
 
Once the Acquire Tail Coil Panel opens, image acquisition settings will 
automatically adjust to empirically verified optimal values for Tail Coil assays. 
However, image acquisition settings can still be modified by the user. 

2 Click Select Alignment to select a Well Alignment File (see Create a Well 
Alignment File for more information, and for instructions on creating a Well 
Alignment File ). 
 
The well plate configuration documented within the selected Well Alignment File 
should match the configuration of the well plate being used in the Tail Coil 
assay. 

3 (Optional) In the Additional Information field, enter any notes about the Tail Coil 
assay being conducted. 

4 To save assay data as an .nc dataset file, select Save to RAM under Save 
Format. 
 
To save assay data as an MP4 file, select Save to MP4 under Save Format. 
 
To save assay data as a CSV file, select Save to CSV under Save Format. 
WARNING: This will not save any video data. 

5 Assay Settings open with preset suggested values. However, to customize 
assay data capture, under Assay Settings, set duration of Acquisition Duration 
as per Tail Coil assay experimental requirements. 

6 Advanced Settings open with preset suggested values. However, to customize 
assay data capture, under Advanced Settings, set values of: 

●​ Pixel Threshold - threshold to be applied to the absolute difference of 
pixels between frames relative to the average of the pixels. 

●​ Difference Threshold - threshold to be applied to the absolute difference 
of pixels between frames. 

●​ Frame Rate - frame rate the assay will acquire video at. 
 
as per Tail Coil assay experimental requirements.  

7 Enter a value in the Start Delay field to delay the start of the assay data capture 
sequence defined in Steps 5 and 6 above. 

8 Click Select File Location to select a workspace. Always select a folder on the 
“MCAM_data” drive to store data from MCAM acquisitions. The “File Location” 
will be displayed in the left side panel once defined. 
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9 Define a Filename to name the folder into which all generated files will be 
saved. A timestamp will be automatically appended to this name. 

10 (Optional) At the top of the panel under “Assay Protocol” click Save to save this 
assay protocol for future use. 
 
In the future, load previously saved assay data capture parameters by clicking 
the Load button under “Assay Protocol” and select the appropriate Tail Coil 
Assay JSON file. 

11 If Save to Ram was selected as the Save Format, click the Prepare Video 
button to set up the MCAM system to capture Tail Coil assay video data. 

12 Click the Acquire Video button to begin Tail Coil assay data capture. 
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Best Focus Panel 

 
 
This feature allows users to find in-focus images for each image in the overall array.  
 

Step Function 

1 Open the MCAM Viewer and click the Open Dataset button. 
 
Click into the raw z-stack of interest, then click Open in the popup to open raw 
z-stack in MCAM Viewer. Note: this tool is only available for stacks not videos. 

2 Go to Tools > Best Focus to open the Best Focus Selection Panel. Upon opening 
the panel, an estimated best focus will be generated. Once completed, the 
interface will automatically zoom to Well H1 and show the best focus frame. 
Click on any well to see its corresponding estimated best focus. 

3 If the estimated best focus is not ideal, it can also be optimized manually by 
using the arrows and position buttons in the Selection Panel. See image above 
for specifications of what each arrow does. Again, this can be done for each 
individual well until ideal focus is achieved (see examples below for an in focus 
and out of focus image). 
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4 Under Save Settings click on Select Directory to choose the file location where 
the Best Focus Image will be saved. As a default it will open up the file location 
of the raw z-stack chosen in step 1. Additionally, choose the save format (either 
TIFF or NetCDF4). 

6 Click Save to compile and save the Best Focus Images. 
 

 
In focus image. 

 
Out of focus image. 
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Stack Projections 
Projections are a way to combine many z frames into one. It selects pixels of a desired 
intensity from every slice throughout the volume to construct a 2D image. The MCAM 
Stack Projection feature allows the user to select if it is constructed based on the 
following intensity options: maximum, minimum, mean, sum and standard deviation.  
 

 
 

Step Function 

1 Open the MCAM Viewer and click the Open Dataset button. 
 
Click into the stack dataset of interest, then click Open in the popup to open the 
stack dataset in MCAM Viewer. 

2 Go to Tools > Stack Projection to open the Stack Projection Panel.  

3 Under Location click on Select Directory to choose the file location where the 
Stack Projection will be saved. As a default it will open up the file location of the 
stack dataset chosen in step 1. 

4 Within Saving Options, select the pixel intensity for the Stack Projection and 
choose the save format (either TIFF or NetCDF4). 

5 Within Slicing Options choose whether the Stack Projection will be taken from 
all the frames (Full Array) or from a specific subset (Subset). If Subset is 
selected, define it by typing the Frame Start and Frame Stop accordingly. 

6 Click Save to combine the stacks into the desired Stack Projection and save it. 
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Full Well Scan 
A full-well scan allows users to scan the entire well of the well plates used in contrast to 
imaging a portion of wells imaged in a single-position image acquisition. Multiple groups 
image scan modes may be possible with your instrument and are configured during 
setup. The example here uses the 3x3 scan mode. 
 

 
 

 
Step Function 

1 Open the MCAM software. 

2 In the MCAM software, go to the top left corner and click on the dropdown 
menu to select the 3x3 scanning mode.  

3 Select the illumination mode of choice on the left panel. 

4 Determine the imaging parameters (brightness, exposure time, analog/digital 
gains), and stage (Z) positions. 

5 Go to Assay > Acquire XYZC stack. A panel should have opened on the right, 
with the last illumination mode of choice and imaging parameters shown in the 
panel. 

6 Enter a “Start height” and “End height” representing z-stage positions where 
the z-stack will start and stop. Sometimes it works well to find an optimal focal 
plane and choose this as the “Mid height” and then set the Start and End a 
millimeter below and above respectively. Enter either “Step size” or “Number 
of Steps” to determine the z-axis resolution. The second of these two 
parameters will update automatically. 

7 Select a File Location. Always select a folder on the “MCAM_data” drive to store 

46 



data from MCAM acquisitions. The “File Location” will be displayed in the panel 
once defined. 

8 Enter a Name for the acquisition. A timestamp will automatically be appended to 
the selected name. 

9 Click Acquire XYZC Stack to initiate the acquisition. 
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Brain Organoid Segmentation 
This assay allows you to identify and measure the size and circularity of brain organoids. 
Data outputs include surface area and circularity. 
 

 
 

Step Function 

1 Open the MCAM Viewer and click the Open Dataset button. 
 
Click into the dataset of interest, then click Open in the popup to open the 
dataset in MCAM Viewer. 

2 Go to Assays > Organoids > Brain Organoid Segmentation to open the Brain 
Organoid Segmentation Panel.  

3 Within Output Options, check Save Masks to see if masks generated 
appropriately cover the organoids. Check Include Filename will result in the 
filename of the output csv file containing the filename of the dataset. 

4 Click Segment Dataset to generate Segment Dataset Outputs. 
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Blob Detection Assay 
The blob detection assay allows you to count the numbers of “blobs”, for example, the 
number of the DAPI-nuclear stained cells. It counts the number of blobs within each field 
of view and outputs a csv of the number of blobs in each field of view. This analysis is 
compatible with 96-, 384-, and 1536-well plates. Blob detection works best for binary 
datasets with high contrast. 

 
Counting DAPI and GFP Blobs 

 
Step Function 

1 Load the well plate onto the Vireo. 

2 Capture an XYZC stack at 4x or 10x magnification, optimally in the DAPI - 
380nm fluorescence channel and Laplacian projection. 

3 Open the acquired dataset in the MCAM Viewer software. 

4 Go to Assays > Blob Detection. A panel will open on the right. 

5 Input minimum and maximum blob radii in um (you can measure blob radius by 
using the circle tool under “Tools”).  

6 Click “Detect Blobs” to run the analysis. 

7 Analysis results are displayed on the screen and saved in a folder named 
“blob_analysis_results” in the parent folder of the analyzed dataset. Two files 
are generated, “analysis_metadata.nc” file containing the analysis results and a 
csv file summarizing the blob count on a per well basis. 
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Confluence Assay - 4x Magnification 
The confluence assay allows you to assess cell growth of 2D adherent cells at 4x 
magnification in one field of view per well measuring the area of cell coverage and 
outputs a csv of the confluence for each well. This assay is optimized for 96-well plates. 
 

 
Confluence in a 96-well plate at 4x magnification 

 
Step Function 

1 Load the 96-well plate onto the Vireo. 

2 Acquire an XYZC stack at 4x magnification with brightfield illumination and 
Laplacian projection. 

3 Open the acquired dataset in the MCAM Viewer software. 

4 Go to Assay > Confluence. A panel will open on the right. 

5 Click “Compute Confluence” to run the analysis. 

6 Analysis results are displayed on the screen and saved in a folder named 
“confluence_results” in the parent folder of the analyzed dataset. Two files are 
generated, “analysis_metadata.nc” file containing the analysis results and a csv 
file summarizing the quantification of confluence on a per well basis. 
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Confluence Assay - 10x Magnification 
The confluence assay allows you to assess cell growth of 2D adherent cells at 10x 
magnification in 4 x 4 overlapping images per well measuring the area of cell coverage 
and outputs a csv of the confluence for each well. This assay is optimized for 96-well 
plates. 
 

 
Unstitched 4x4 image scan of a 96-well plate well showing overlap regions that are excluded. 
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Step Function 

1 Load your 96-well plate onto the MCAM. 

2 Acquire an XYZC stack at 10x magnification with a 4x4 well plate scan with 
focused brightfield illumination and Laplacian projection. Please see the 
workflow guide for “Full Wellplate Scan” for more information on acquisition. 

3 Open the acquired dataset in the MCAM™ Viewer software. 

4 Go to Assay > Confluence. A panel will open on the right. 

5 Select a well alignment file specific to the well plate in use. Please see “Create 
a Well Alignment File” for more information. 

6 Click “Compute Confluence” to run the analysis. 

7 Analysis results are displayed on the screen and saved in a folder named 
“confluence_results” in the parent folder of the analyzed dataset. Two files are 
generated, “analysis_metadata.nc” file containing the analysis results and a csv 
file summarizing the quantification of confluence on a per well basis. 

8 Interpretation: Regions outside of the well alignment radius are excluded. 
Regions in one half of overlapping images are excluded. The bottom and right 
overlap margins are excluded selectively. The percent confluent is displayed in 
the bottom left corner of the screen. 
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Segmentation 
This tool allows the identification and measurements of various parameters of the 
samples imaged (organoids and adherent cells; size, surface area, confluence, counts, 
circularity, eccentricity).  
 

 
 

Step Function 

1 Open the MCAM Viewer and click the Open Dataset button. 
 
Click into the dataset of interest, then click Open in the popup to open the 
dataset in MCAM Viewer. 

2 Go to Assays > Segmentation to open the Segmentation Panel.  

3 Within Bounding Box Model Selection Options, several options are available. 
For organoids, choose “Organoid Focus” or “Single Organoid Focus” for 
samples with single organoids in wells; “Multi Organoids” for samples with 
multiple organoids in wells. Data outputs are size, total surface area, circularity, 
eccentricity (Single and Multi Organoid Focus), count, surface areas of 
individual organoids, and confluence (in Multi Organoids). 
For 2D adherent cells, choose “Fibroblast Focus”. Data outputs are cell count 
and confluence. 

4 Select “Laplacian” for the projection. 

5 Click Segment Dataset to initiate the analysis and generate Segmented Dataset 
Outputs. 
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Tiny Organoid Wellplate Scans 
The goal of this assay workflow is to detect and analyze one small object within an image 
group of high magnification MCAM images. When imaging a 96-well plate at 10x 
magnification with the Vireo, it is necessary to scan the well plate, acquiring multiple 
overlapping images of each well which are stitched together for visualization. Within the 
image group we look to detect the object of interest in all images and then filter out those 
on the edges of images followed by selecting the one found that the algorithm is most 
confident of, and then analyze the single best with regard to area and circularity. The 
following workflow steps through acquisition, data reduction, and analysis of grouped 
image datasets for single object detection and analysis of tiny organoids. 
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Step Function 

1 Acquire a well plate scan using the 10x 3x3 acquisition mode described in the 
Workflow Guide SOP “Full Well Scan”. 

2 Locate and open your acquired XYZC-stack acquisition dataset in the MCAM 
Viewer by either double clicking on the metadata.nc file or opening the Viewer 
software from the left desktop toolbar and drag and drop the metadata.nc file 
into the Viewer. 

3 Project the dataset following the instructions described in the “Stack 
Projections” workflow protocol selecting the “Tiny Organoid” projection. 

4 Once the projection processing has completed, close the MCAM Viewer 
window, locate and open the newly projected dataset in the MCAM viewer. 

5 Go to Assays > Segmentation. 

6 Select the “Tiny Single Organoid Focus” model. Both filters “Filter Boundary” 
and “Filter Highest Confidence” are correctly selected by default when using 
this model. 

7 Click Segment Dataset to initiate the analysis. 

8 Visualization of the segmentation results is overlaid on images in the MCAM 
Viewer and quantified metric results are exported in .CSV format in the 
“segmentation_analysis_results” folder located within the focus projection 
dataset directory. 
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Stitching Multi-Image Well Datasets 
This workflow utilizes the Well Alignment tool to stitch the images from acquisitions that 
contain multiple images per well together at a desired resolution. This is useful for data 
reduction as well as simplifying downstream analysis. The newly exported dataset can 
then be used with analysis panels such as the Segmentation panel or the Brain Organoid 
Segmentation panel. 
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Step Function 

1 Acquire a well plate scan using an acquisition mode that captures multiple 
images per well such as the “Full Well Scan” acquisition. 

2 Locate and open your acquired XYZC-stack acquisition dataset in the MCAM 
Viewer by either double clicking on the metadata.nc file or opening the Viewer 
software from the left desktop toolbar and drag and drop the metadata.nc file 
into the Viewer. 

3 Open the Well Alignment panel by navigating to Tools>Well Alignment in the 
viewer top level menu. 

4 Specify the well diameter, columns and rows of your acquired well plate. 

5 Click Detect Well Alignment 

6 Verify the red circles diameter fits your wells across images 

7 Drag the 4 corner circles to their correct positions fit over the corner wells using 
the middle red circles 

8 Click Update Well Alignment 

9 Check Stitched Wells 

10 Check Stitched Resolution 

11 Specify desired resolution. (3072 recommended) 

12 (Optionally) Click Save Well Alignment to save this protocol for future use 

13 Click Export Well Images to export a stitched dataset.  
This dataset can then be used in our analysis panels such as the Segmentation 
panel. 
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